
 
 

 
 

 
 

 

Utilizing the Inspection Tool 

 
Summary 

 
This guide will describe the eGovFrame’s Code Inspection tool called PMD and its basic usage. 

 
Basic manual 

 
You can run Code Inspection from the IDE’s PMD Perspective in order to batch-inspect code conveniently. 

 
Switching to PMD Perpective 

Following is how to switch to the PMD Perspective. 

1. Choose 'Window' > 'Open Perspective' > 'Other…' from the menu 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
2. Choose PMD from the Open Perspective window 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
3. After switching to the PMD Perspective, you will see Package Explorer, Violation Outline, Violation Overview and other views within the IDE.



 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Running code inspection 
 

Choose a project to inspect. 

In the Package Explorer, right-click on the project, and choose PMD > Check Code with PMD in the context menu. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The entire project’s source code will be inspected. If you want to run inspections only on individual source files, apply the same step as above on the 

files from the Package Explorer. 

Only Java source codes will run through the inspection, and the following will be excluded.



 
 

 

 
Include files 

JAR files and other binaries 

 
Inspection results 

 
After the inspection, you can check the results and see the violating codes. 

PMD Perspective provides multiple views for you to see the inspection results. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Package Explorer 

If there are violating code areas within the project, similar to compile errors, the project icon and the violating source icons in the Package Explorer will 

display red X boxes as below. ( )

These icons will persist until the violations have been corrected. 
Problem view 

Problem view will list the violating lines in the source code. Open the Problem view in the PMD Perspective as follows. 

1. Window > Show View > Other… in the Eclipse menu 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
2. In the Show View dialog, choose Problem under the General category.



 
 

 
 

 
 

Category Description Description Detailed description of the violation Resource Violating file name Path Violating file’s path Location Violating line number  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Use the Problem view to see the violating lines, and access them in the editor to fix the violated source codes. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Double-clicking an entry will jump to the violating line in the Editor. 

 
Violations Overview view 

Using Violations Overview will be described in the Reporting inspection results section later on. 

 
Resetting inspection results 

 
Inspection results will persist on the source until you edit them. 

You may need to reset the inspection results because it may be confusing to distinguish between inspection results and code compile error results. Or, if you 

want to re-run inspection, you need to reset inspection results. 

In order to reset inspection results, choose a project and reset it as below. 

In the Package Explorer, right-click on the project, and choose PMD > Clear PMD Violations from the context menu. 



 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

This will reset the inspection results, and will hide the Problem view, Violations Overview view, and Package Explorer view in the IDE. 

 
eGovFrame standard inspection rules 
 

 

 

eGovFrame defines total of 39 rules for Code Inspection in terms of logical/phrase/reference errors. eGovFrame rule set needs to be installed according to the 

standard installation guideline; each rule will be explained in the following sections, as well as examples of violating codes, remedies, and compliant codes. 

 
Rule#01. EmptyCatchBlock 

Description: using empty catch statements 

Problematic code: 

 
public void doSomething() { 

try 

{ 

FileInputStream fis = new FileInputStream("/tmp/bugger"); 

} 

catch (IOException ioe) 

{ 

// 

} 

} 

 
Recommendation: Always use handling code in catch blocks 

 
Rule#02. EmptyIfStmt 

Description: empty if conditions 

 



 
 

 

 
Problematic code: 

 
public class Foo { 

void bar(int x) { 

if (x == 1) { 

// 

} 

} 

} 

 
Recommendation: avoid empty if conditions 

 

Rule#03. EmptyWhileStmt 

Description: empty while conditions 

Problematic code: 

 
public class Foo { 

void bar(int a, int b) { 

while (a == b) { 

// 

} 

} 

} 

 
Recommendation: avoid empty while conditions 

 
Rule#04. EmptyTryBlock 

Description: empty try conditions 

Problematic code: 

 
public class Foo { 

public void bar() { 

try 

{ 

} 

catch (Exception e) 

{ 

e.printStackTrace(); 

} 

} 

} 

 
Recommendation: avoid empty try conditions 

 
Rule#05. EmptyFinallyBlock 

Description: empty finally statements 

Problematic code: 

 
public class Foo { 

public void bar() { 

try 

{ 

int x=3; 

} 

finally 

{ 

// 

} 

} 

} 

 

Recommendation: there must not be any empty finally statments 
 

 

ule#06. UnnecessaryConversionTemporary 

Unnecessary String conversions into temporary variables 

Problematic code: 

 
public String convert(int x) {



 
 

 

 
public String convert(int x) { 

String foo = new Integer(x).toString(); 

return foo; 

} 

 
Recommendation: when converting data type into String, avoid creating temporary String variables 

 
Rule#07. EmptyStatementNotInLoop 

Description: unnecessary semi-colons 

Problematic code: 

 
public class MyClass { 

public void doit() { 

; 

System.out.println("look at the extra semicolon");; 

} 

} 

 
Recommendation: avoid using empty statements with semi-colons only. 

 
Rule#08. WhileLoopsMustUseBraces 

Description: bracket-less while statements 

Problematic code: 

 
public void doSomething() { 

while (true) 

x++; 

} 

 
Recommendation: avoid using while statements without brackets 

 
Rule#09. AssignmentInOperand 

Description: assignments within conditions/operands 

Problematic code: 

 
public class Foo { 

public void bar() { 

int x = 2; 

if ( (x = getX() ) == 3) { 

System.out.println("3!"); 

} 

} 

private int getX() { 

return 3; 

} 

} 

 
Recommendation: avoid using assignments in conditions/operands, because it decreases code readability and increases complixity 

 
Rule#10. UnnecessaryParentheses 

Description: unnecessary parentheses 

Problematic code: 

 
public class Foo { 

boolean bar() { 

return (true); 

} 

} 

 
Recommendation: avoid unnecessary parentheses, because it decreases code readability 

 
Rule#11. SimplifyBooleanExpressions 

Description: unnecessary boolean comparisons 

Problematic code: 

 
public class Bar { 

private boolean bar = (isFoo() == true);



 
 

 
 

private boolean bar = (isFoo() == true); 

 
public isFoo() { 

return false; 

} 

} 

 
Recommendation: avoid using unnecessary boolean comparisons 

 
Rule#12. SwitchStmtsShouldHaveDefault 

Description: default-less switch statements 

Problematic code: 

 
public class Foo { 

public void bar() { 

int x = 2; 

switch (x) { 

case 2; 

int j = 8; 

} 

} 

} 

 
Recommendation: always define switch label in switch statements 

 
Rule#13. AvoidReassigningParameters 

Description: reassigning parameters 

Problematic code: 

 
public class Foo { 

private void foo(String bar) { 

bar = "something else"; 

} 

} 

 
Recommendation: parameters shall not be modified in value. 

 
Rule#14. FinalFieldCouldBeStatic 

Description: using static instead of final 

Problematic code: 

 
public class Foo { 

public final int BAR = 42; 

} 

 
Recommendation: switching to static instead of final can reduce overhead 

 
Rule#15. EqualsNull 

Description: null comparison using equals() 

Problematic code: 

 
class Bar { 

void foo() { 

String x = "foo"; 

if (x.equals(null)) { 

doSomething(); 

} 

} 

} 

 
Recommendation: equals method shall not be used for comparing null values 

 
Rule#16. SimpleDateFormatNeedsLocale 

Description: locale-less SimpleDateFormat 

Problematic code:



 
 

 

 
public class Foo { 

private SimpleDateFormat sdf = new SimpleDateFormat("pattern"); 

} 

 
Recommendation: always assign locale when using SimpleDateFormat 

 
Rule#17. ImmutableField 

Description: use final for constructor variables 

Problematic code: 

 
public class Foo { 

private int x; 

public Foo() { 

x = 7; 

} 

public void foo() { 

int a = x + 2; 

} 

} 

 
Recommendation: use final variable type for constructor variables 

 
Rule#18. AssignmentToNonFinalStatic 

Description: erroneous usage of static type 

Problematic code: 

 
public class StaticField { 

static int x; 

public FinalFields(int y) { 

x = y; 

} 

} 

 
Recommendation: avoid using static fields in unsafe manner 

 
Rule#19. AvoidSynchronizedAtMethodLevel 

Description: overusing synchronization at method level 

Problematic code: 

 
public class Foo { 

synchronized void foo() { 

} 

} 

 
Recommendation: use synchronization only for blocks rather than methods 

 
Rule#20. AbstractClassWithoutAbstractMethod 

Description: defining abstract class without abstract methods 

Problematic code: 

 
public abstract class Foo { 

void int method1() { 

// ... 

} 

void int method2() { 

// ... 

} 

} 

 
Recommendation: always define abstract methods in abstract classes 

 
Rule#21. UncommentedEmptyMethod 

Description: comment-less empty methods 

Problematic code: 

 

 
public void doSomething() { 

}



 
 

 

 
} 

 
Recommendation: always indicate empty methods with comments 

 
Rule#22. AvoidConstantsInterface 

Description: using constants in interfaces 

Problematic code: 

 
public interface ConstantsInterface { 

public static final int CONSTANT1 = 0; 

public static final String CONSTANT2 = "1"; 

} 

 
Recommendation: use interfaces only for defining class behaviors 

 
Rule#23. DuplicateImports 

Description: duplicate import statements 

Problematic code: 

 
import java.lang.String; 

import java.lang.*; 

 
public class Foo { 

} 

 
Recommendation: avoid using duplicate import statements 

 
Rule#24. ImportFromSamePackage 

Description: importing from same package 

Problematic code: 

 
package foo; 

import foo.Buz; 

import foo.*; 

 
public class Bar { 

} 

 
Recommendation: avoid importing from same package 

 
Rule#25. SystemPrintln 

Description: using System.out.print 

Problematic code: 

 
class Foo{ 

public void testA () { 

System.out.println("Entering test"); 

} 

} 

 
Recommendation: avoid System.out.print, instead use customized message printing 

 
Rule#26. VariableNamingConventions 

Description: under-bars in variable names 

Problematic code: 

 
public class Foo { 

public static final int MY_NUM = 0; 

public String myTest = ""; 

DataModule dmTest = new DataModule(); 

} 

 
Recommendation: do not include underlines for variables that are not final 

 
Rule#27. MisleadingVariableName 



 
 

 
 

Description: using erroneous prefixes for variables 

Problematic code: 

 
public class Foo { 

public void bar(String m_baz) { 

int m_boz = 42; 

} 

} 

 
Recommendation: avoid using m_ prefixes for non-fields 

 
Rule#28. AvoidArrayLoops 

Description: loops for copying arrays 

Problematic code: 

 
public class Test { 

public void bar() { 

int[] a = new int[10]; 

int[] b = new int[10]; 

for (int i=0;i<10;i++) { 

b[i]=a[i]; 

} 

} 

} 

 
Recommendation: avoid loops and instead use System.arraycopy() for array copies 

 
Rule#29. UnnecessaryWrapperObjectCreation 

Description: unnecessary WrapperObjects 

Problematic code: 

 
public int convert(String s) { 

int i, i2; 

i = Integer.valueOf(s).intValue(); 

i2 = Integer.valueOf(i).intValue(); 

 
Recommendation: use custom parse-related methods instead 

 
Rule#30. AvoidThrowingRawExceptionTypes 

raw exception types 

Problematic code: 

 
public class Foo { 

public void bar() throws Exception { 

throw new Exception(); 

} 

} 

 
Recommendation: use more specific exceptions 

 
Rule#31. AvoidThrowingNullPointerException 

Description: using null pointer exceptions 

Problematic code: 

 
public class Foo { 

void bar() { 

throw new NullPointerException(); 

} 

} 

 
Recommendation: avoid using NullPointerException 

 
Rule#32. StringInstantiation 

Description: using unnecessary String instances 

Problematic code: 

 
public class Foo {



 
 

 

 
public class Foo { 

private String bar = new String("bar"); 

} 

 
Recommendation: use more simple variables 

 
Rule#33. StringToString 

Description: using toString() on a String instance 

Problematic code: 

 
public class Foo { 

private String baz() { 

String bar = "howdy"; 

return bar.toString(); 

} 

} 

 
Recommendation: avoid calling toString() on String instances 

 
Rule#34. InefficientStringBuffering 

Description: combining strings inside StringBuffer() constructor 

Problematic code: 

 
StringBuffer sb = new StringBuffer( "tmp =" + 

System.getProperty("java.io.tmpdir") ); 

 
Recommendation: use append method instead 

 
Rule#35. InefficientEmptyStringCheck 

Description: using null check or zero size check on Strings 

Problematic code: 

 
public class Foo { 

void bar(String string) { 

if (string != null && string.trim().size() > 0) { 

doSomething(); 

} 

} 

} 

 
Recommendation: use custom logic instead to differentiate whitespace and non-whitespace 

 

 
Rule#36. UselessStringValueOf 

Description: using String.valueOf() when appending 

Problematic code: 

 
public String convert(int i) { 

String s; 

s = "a" + String.valueOf(i); 

return s; 

} 

 
Recommendation: avoid calling String.valueOf() when appending 

 
Rule#37. UnusedPrivateField 

Description: unused private fields 

Problematic code: 

 
public class Something { 

private static int FOO = 2; // Unused 

private int i = 5; // Unused 

private int j = 6; 

 
public int addOne() { 

return j++; 

}



 
 

Personal IDE: Check results in Violations Overview of Eclipse IDE or use file-based reporting in CSV
1)
, HTML, TXT, or XML. 

Server IDE: Using CI server, Hudson2), Hudson PMD Hudson’s PMD Plugin can be used for inspection reports. See eGovFrame’s Hudson 
Code Inspection Tools guide. 

 

 
 

} 

} 

 
Recommendation: avoid unused private fields 

 
Rule#38. UnusedPrivateMethod 

Description: unused private methods 

Problematic code: 

 
public class Something { 

private void foo() {} // unused 

} 

 
Recommendation: avoid unused private methods 

 
Rule#39. UnusedFormalParameter 

Description: unused method parameters 

Problematic code: 

 
public class Foo { 

private void bar(String howdy) { 

// howdy is not used 

} 

} 

 
Recommendation: avoid unused method parameters 

 
Reporting inspection results 

 
You can aggregate and report inspection results as below. 

 

 

 

 
Reports in Violations Overview 

 
Inspection results can be checked immediately in the IDE as below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Violations Overview displays a grid for listing statistic violating codes, and control buttons to control the grid on the top right. 

 

Button functionalities 

 

Statistics button: refreshes the statistics grid. Should be used after using the priority button, or any violation  

is fixed. 

 

Priority buttons: filters violating items in the grid. Five, different-colored buttons that denote from 1 to 5 (low to high, from left to 

right). 1s and 2s (red and orange) are must-fixes. Each button are toggle-style buttons. 

 

 Collapse statistics button: collapses all the statistics items in the grid to initial state. 

 

 View menu: selects sorting method for the grid. The options are as follows: 

Show violations to packages: sorts violating items by packages. 

Show violations to files: sorts violating items by files. 

Show packages with files: sort by packages, along with displaying file information. 

 
Grid components 



 
 

 
 

 

 
 

 
Element: violating packages, files, and detailed information. 

Violations: violation count for the selected element. 

3) 

Violations/LOC: parts-per-thousand (per-mil), as in violations per 1,000 lines of code. 

Violations/Method: violations per method, or average violations per method for package elements. 

Project: name of project that the selected violating element belongs to. 

These statistical information can be utilized by the developer, directly from the IDE, for improving code quality. 

 
Per-file report generation 

 
To generate per-file reports, choose a project, then proceed as follows. 

 

In Package Explorer, choose Project, then right-click on it. 

In the context menu, choose PMD > Generate reports. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Confirm generated report 
 

Multiple file formats are supported for per-file inspection report generation. 

CSV, HTML, TXT, and XML files can be created under the reports folder inside the project.



 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Reviewing reports 
 

Reports display all the inspection results in a single file view. Following is an example of an HTML report file opened in a browser. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fixing broken Korean fonts in reports 

PMD’s report files use UTF-8 encoding to generate Korean text, so if you see broken Korean fonts follow the guideline below.  

 

Web browser : opening HTML reports, and your encoding is set to Korean: 

Switch to UTF-8 (Unicode). 

Microsoft Internet Explorer: 

From the menu bar, choose View > Encoding > Unicode (UTF-8) 

Mozilla Firefox: 

From the menu bar, choose View > Character encoding > Unicode (UTF-8) 

Google Chrome: 

Click the Customize and Control button to the right of the URL field, then choose Encoding > Unicode (UTF-8) 

Microsoft Excel: does not support CSV files in UTF-8 

Open such CSV files with text editors such as Notepad, store in a different encoding other than UTF-8, then open  

with Excel. 

Use Notepad as below. 

1. Open the CSV file with Notepad, then choose File > Save as ... from the menu. 

2. In the dialog, choose All files in the file type drop-down menu. 

3. Choose ANSI or Unicode encoding, then save the file. 

4. Open the file with Excel. 

Hudson PMD Plugin tool has a bug of Hudson PMD Plugin used in reporting PMD using the remote CI server, Hudson and cannot recognize UTF-8-based 

Korean (or other Asian) rule set files. 

Until the bug fix is patched, you need to use english rule set file in order to use the PMD plug-in. 

 
 

Utilizing inspection report statistics 
You can use the hudson PMD Plugin to utilize the statistical information in the inspection reports. 



 
 

 

To search statistics on violations from Hudson, it is confirmed as following. 

 

In the Hudson Dashboard, choose a project to review 

Choose PMD Warning from the left menu 

Next is the initial statistics screen. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
PMD result view 

 
Warnings Trend: statistical trend of code inspection warnings in the project 

All Warnings: total number of warnings occurred in the project 

New Warnings: number or warnings from the most recent build 

Fixed Warnings: number of fixed warnings in the most recent build 

Summary: displays statistics sorted by priorities (High/Normal/Low) 

Detail: displays detailed statistics with tabbed items as below 

Packages: statistics per packages 

Files: statistics per files 

Types: statistics per violation types 

Warnings: all warnings 

Details: all warnings with detailed information 

New: new or unfixed warnings with detailed information 

 
Detailed statistics view 

Hudson PMD Plugin’s statistics can be used to measure individual or team performances as well as metrics for code quality improvement. 

 
Packages 

Displays per-package violations as below.



 
 

 
 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Files 

Displays per-file violations as below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Types 

Displays per-type violations as below.. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Warnings 

Displays all warnings as below.



 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
1) 

2) 

3) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Comma Separated Value 

Continuous integration 

Line of Code 


